Zato installation problem on Ubuntu 16.04 with MySQL

Hello,

I am experiencing a problem when doing a fresh install of Zato on Ubuntu 16.04 with a MySQL db, following the instructions https://zato.io/docs/admin/guide/install/ubuntu.html

When I run the quickstart command I get the following errors (output shortened):

File \"/opt/zato/current/bin/zato\", line 183, in <module>
    sys.exit(zato.cli.zato_command.main())
File \"/opt/zato/2.0.7/zato-cli/src/zato/cli/create_web_admin.py\", line 149, in execute
      call_command('migrate', run_syncdb=True, interactive=False, verbosity=0)
File \"/opt/zato/2.0.7/eggs/Django-1.9.3-py2.7.egg/django/core/management/commands/migrate.py\", line 200, in handle
      executor.migrate(targets, plan, fake=fake, fake_initial=fake_initial)
File \"/opt/zato/2.0.7/eggs/PyMySQL-0.6.2-py2.7.egg/pymysql/err.py\", line 112, in _check_mysql_exception
      raise InternalError(errno, errorvalue)\nInternalError: (1170, u\"BLOB/TEXT column 'claimed_id' used in key specification without a key length\")", 

It seems that the problem lies with the change from “call_command(‘syncdb’, interactive=False, verbosity=0)” to “call_command(‘migrate’, run_syncdb=True, interactive=False, verbosity=0)”, which was used previously.

The description of the problem for django can be found here: https://openedx.atlassian.net/browse/TNL-3664

Is it really that issue or am I missing some configuration/dependencies?

with kind regards,

Martin Zofka

Hello @marzof,

many thanks for raising the question - I will be sure to look into it.

Would you be so kind as to quote the description from the Jira ticket that you are referring to? It appears that it’s a private instance and I cannot access it.

Hello @dsuch,

This is the description of the ticket:


django-openid-auth has claimed_id = TextField(unique=True). However, TextFields cannot be unique in MySQL: https://github.com/django/django/commit/e8cbc2b322d873a6fe39faca18d340ce93035087
https://docs.djangoproject.com/en/1.8/ref/models/fields/#textfield
https://code.djangoproject.com/ticket/2495
This results in the following error when running migrations:
"django.db.utils.OperationalError: (1170, “BLOB/TEXT column ‘claimed_id’ used in key specification without a key length”)"
In Django 1.4, unique=True on TextField was ignored during migrations, so production does not have a unique index on the claimed_id field either.

No idea why the page is no longer publicly accessible, but I had to load it from the cache.

Hope it helps, regards M.

Hi @marzof - I’d like to upload a 2.0.8rc1 version for you to confirm if it still occurs in this revision, can you tell me if it is Ubuntu 16.04 32-bit or 64-bit?

Thanks.

Hi @dsuch,

It is the Ubuntu 16.04 64-bit version.

Thanks.

@marzof - can you check this one out? https://zato.io/support/forum/zato-2.0.8-rc1_amd64-xenial.deb

@dsuch - I couldn’t get it to work. I still get the same error:

InternalError: (1170, u"BLOB/TEXT column 'claimed_id' used in key specification without a key length")

I ran the the installation and then the quickstart, is anything else required?

Thanks @marzof, nothing else is needed - I will investigate it further.

I have prepared 2.0.8rc2 for you, @marzof - can you give it a try, please?

https://zato.io/support/forum/zato-2.0.8-rc2_amd64-xenial.deb

Hi @marzof - have you had an opportunity to test 2.0.8rc2? I’m waiting only for your feedback before 2.0.8 can be released. Thanks.

Hi @dsuch,

sorry I didn’t notice your message about 2.0.8rc2.

I tested it now and everything seems to be fine.

Thank you!

Hi @dsuch,

is there any date when 2.0.8 will be released? You mentioned before that this issues was the last to be resolved before the relase.

regards,

M

Hi @marzof,

there were perturbations that, unfortunately, delayed the 2.0.8 release, but it will be done in August for sure.

Regards.

Just a quick update that final packages for 2.0.8 are being built as we speak - this will take several days but the release is on its way.