Unrecognized arguments error when trying to create a Cluster

Hello.

We have found that when we try to create a cluster (following the steps on " How to create a distributed cluster" from here ) the zato create cluster command fails, throwing an error:

zato: error: unrecognized arguments: --broker_host <invalid-broker-host> --broker_port 12345

The command used was:

/opt/zato/current/bin/zato create cluster \
    zato-local \
    --odb-type mysql \
    --odb-host 127.0.0.1 \
    --odb-port 3306 \
    --odb-db-name zato_repo \
    --odb-user zato \
    --lb-host 192.168.0.42 \
    --odb-password zato

(Note, this was used after successfully creating the ODB as per the instructions on the docs)

After some testing, this seems to be related to the changes introduced here: GH #1194 - Turning '_' in CLI options into '-'. · zatosource/zato@9ed0642 · GitHub

I say that because if I checkout (git checkout) the commit before that change and use the previous format of the params (with “_”), it works flawlessly:

/opt/zato/current/bin/zato create cluster \
  zato-local \
  --odb_type mysql \
  --odb_host 127.0.0.1 \
  --odb_port 3306 \
  --odb_db_name zato_repo \
  --odb_user zato \
  --lb_host 192.168.0.42 \
  --odb_password zato

Am I missing something?

Thanks in advance for the help.

Thanks, I will have a look.

However, I am not sure who you mean by “we”. It would be great if you could introduce yourself, your group and company, and describe what you are building so that the context of your inquires becomes clearer.

Regards.