Unable to access services/ channels etc from web-admin :: Distributed cluster

Hi forum, I have this problem, if anyone have an idea that what is, please let me know

Created a distributed zato cluster in EKS. Started the each component with the following commands


	Error from Dasboard: line 516, in send raise ConnectionError(e, request=request) requests.exceptions.ConnectionError: HTTPConnectionPool(host='127.0.0.1', port=11223): Max retries exceeded with url: /zato/admin/invoke (Caused by NewConnectionError(': Failed to establish a new connection: [Errno 111] Connection refused'))

	Logs from Dashboard: 
		INFO - 34:MainThread - zato.admin.web.views:446 - Invoking zato.service.get-list with {'cluster_id': 1, 'paginate': True, 'query': None, 'cur_page': None}
	2022-09-08 15:11:49,081 - WARNING - 34:MainThread - urllib3.connectionpool:780 - Retrying (Retry(total=9, connect=3, read=None, redirect=None, status=None)) after connection broken by 'NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7fdb31a7cc40>: Failed to establish a new connection: [Errno 111] Connection refused')': /zato/admin/invoke
	
	logs from server:
Traceback (most recent call last):
  File "/opt/zato/3.2.0/code/zato-broker/src/zato/broker/client.py", line 157, in _rpc_invoke
    return self.server_rpc.invoke_all('zato.service.rpc-service-invoker', msg, ping_timeout=10)
  File "/opt/zato/3.2.0/code/zato-server/src/zato/server/connection/server/rpc/api.py", line 128, in invoke_all
    response = invoker.invoke_all_pids(service, request, *args, **kwargs)
  File "/opt/zato/3.2.0/code/zato-server/src/zato/server/connection/server/rpc/invoker.py", line 258, in invoke_all_pids
    return self._invoke(self.invoker.invoke, skip_response_elem=skip_response_elem, *args, **kwargs)
  File "/opt/zato/3.2.0/code/zato-server/src/zato/server/connection/server/rpc/invoker.py", line 157, in _invoke
    requests_get(self.ping_address, timeout=ping_timeout)
  File "/opt/zato/3.2.0/code/lib/python3.8/site-packages/requests/api.py", line 75, in get
    return request('get', url, params=params, **kwargs)
  File "/opt/zato/3.2.0/code/lib/python3.8/site-packages/requests/api.py", line 61, in request
    return session.request(method=method, url=url, **kwargs)
  File "/opt/zato/3.2.0/code/lib/python3.8/site-packages/requests/sessions.py", line 542, in request
    resp = self.send(prep, **send_kwargs)
  File "/opt/zato/3.2.0/code/lib/python3.8/site-packages/requests/sessions.py", line 658, in send
    r = adapter.send(request, **kwargs)
  File "/opt/zato/3.2.0/code/lib/python3.8/site-packages/requests/adapters.py", line 529, in send
    raise ReadTimeout(e, request=request)
requests.exceptions.ReadTimeout: HTTPConnectionPool(host='100.64.13.108', port=17010): Read timed out. (read timeout=10)

Creation commands:

	ODB:
		/opt/zato/current/bin/zato create odb \
                --skip-if-exists \
                 --odb-type postgresql \
                 --odb-host $ODB_HOST \
                 --odb-port 5432 \
                 --odb-user $ODB_USER \
                 --odb-db-name $ODB_DB \
                 --odb-password $ODB_PASSWORD \
                 --postgresql-schema public \
                 --verbose
    cluster:
    	/opt/zato/current/bin/zato create cluster $ENV \
                --odb-type postgresql \
                --odb-host $ODB_HOST \
                --odb-port 5432 \
                --odb-user $ODB_USER \
                --odb-db-name $ODB_DB \
                --odb-password $ODB_PASSWORD \
                --postgresql-schema public \
                --admin-invoke-password $Zato_Dashboard_Password \
                --secret-key $SECRET_KEY \
                --verbose
    webadmin:
    	/opt/zato/current/bin/zato create web-admin \
                      opt/zato/$ENV/$ZATO_POSITION/ \
                     --odb-type postgresql \
                     --odb-host $ODB_HOST \
                     --odb-port 5432 \
                     --odb-user $ODB_USER \
                     --odb-db-name $ODB_DB \
                     --odb-password $ODB_PASSWORD \
                     --postgresql-schema public \
                     --admin-invoke-password $Zato_Dashboard_Password \
                     --verbose
    server:
    	/opt/zato/current/bin/zato create server opt/zato/$ENV/$ZATO_POSITION/ \
                      $ENV \
                     "$(hostname)-$RANDOM" \
                     --odb-type postgresql \
                     --odb-host $ODB_HOST \
                     --odb-port 5432 \
                     --odb-user $ODB_USER \
                     --odb-db-name $ODB_DB \
                     --odb-password $ODB_PASSWORD \
                     --scheduler-host  scheduler \
                     --postgresql-schema public \
                     --secret-key $SECRET_KEY \
                 --verbose
    scheduler:
    	/opt/zato/current/bin/zato \
            create scheduler \
            opt/zato/$ENV/$ZATO_POSITION/ \
            --server-host server \
            --server-port 17010 \
            --odb-type postgresql \
            --odb-host $ODB_HOST \
            --odb-port 5432 \
            --odb-user $ODB_USER \
            --odb-db-name $ODB_DB \
            --odb-password $ODB_PASSWORD \
            --secret-key $SECRET_KEY \
            --postgresql-schema public \
            --verbose


    startup commands:
    	/opt/zato/current/bin/zato start  /opt/zato/$ENV/$ZATO_POSITION/  --fg \
                 --verbose
LB_HOST and LB_PORT: server:17010 [k8s server svc and port 17010]

Did I set up the cluster correctly, am I missing any setting. Followed this guide. https://zato.io/en/docs/3.2/arch/guide/production/distributed/index.html

Didn’t setup loadbalancer for my zato cluster. Are there any loadbalancer settings to be made?