(Migrated) Zato seems to be working, but nothing happens

(This message has been automatically imported from the retired mailing list)

Hi,

I installed zato following the instructions in
https://zato.io/docs/admin/guide/install-zato.html in a Ubuntu 13.10.

One difference was that i didn’t run the installation script, I did all the
commands manually.

I didn’t run into problems and everything went smoothly. then I started the
tutorial using quickstart, the run the check-config for both server1 and
server2, everything ok.

Next step:
$ ./zato-qs-start.sh
Starting the Zato quickstart environment
Running sanity checks
[1/6] Redis connection OK
[2/6] SQL ODB connection OK
[3/6] Load-balancer started
[4/6] server1 started
[5/6] server2 started
[6/6] Web admin started
Zato quickstart environment started
Visit https://zato.io/support for more information and support options

and then:
$ curl localhost:11223/zato/ping -d '{}'
curl: (7) Failed connect to localhost:11223; Connection refused

I search for log files and they are all empty or non existing.

–BMS

On 02/01/2014 03:20 PM, Bruno Silva wrote:

$ ./zato-qs-start.sh
Starting the Zato quickstart environment
Running sanity checks
[1/6] Redis connection OK
[2/6] SQL ODB connection OK
[3/6] Load-balancer started
[4/6] server1 started
[5/6] server2 started
[6/6] Web admin started
Zato quickstart environment started
Visit https://zato.io/support for more information and support options

and then:
$ curl localhost:11223/zato/ping -d '{}'
curl: (7) Failed connect to localhost:11223; Connection refused

Hi Bruno,

the process of starting the servers is asynchronous so the servers have
started but it looks they are having problems with initialization.

Ubuntu 13.10 is not one of the systems Zato has been tested on but let’s
try to get it working.

Can you please send me the full path to server1? I’ll then ask you to
issue a couple of commands and post back their output.

thanks,

On 02/01/2014 03:20 PM, Bruno Silva wrote:

$ ./zato-qs-start.sh
Starting the Zato quickstart environment
Running sanity checks
[1/6] Redis connection OK
[2/6] SQL ODB connection OK
[3/6] Load-balancer started
[4/6] server1 started
[5/6] server2 started
[6/6] Web admin started
Zato quickstart environment started
Visit https://zato.io/support for more information and support options

and then:
$ curl localhost:11223/zato/ping -d '{}'
curl: (7) Failed connect to localhost:11223; Connection refused

Hi Bruno,

the process of starting the servers is asynchronous so the servers have
started but it looks they are having problems with initialization.

Ubuntu 13.10 is not one of the systems Zato has been tested on but let’s
try to get it working.

Can you please send me the full path to server1? I’ll then ask you to
issue a couple of commands and post back their output.

thanks,