(Migrated) strange beaviour

(This message has been automatically imported from the retired mailing list)

Hi.

I’ve created a service and uloaded a py file. Then I modified the py file
and uploaded it again (in logs upload and distribution went well), but if I
execute it, it executes the old version.
If I look in services, the source code is correct, but it continues to
execute an old version of that service.

I try to delete and re-create it, but nothing, always the old version is
executed.

How to execute the new version?

Thank you

On 03/27/2014 04:38 PM, Giovanni Colapinto wrote:

I’ve created a service and uloaded a py file. Then I modified the py file
and uploaded it again (in logs upload and distribution went well), but if I
execute it, it executes the old version.
If I look in services, the source code is correct, but it continues to
execute an old version of that service.

I’ve never seen such a thing - does it persist if you restart the server?

On 03/27/2014 04:38 PM, Giovanni Colapinto wrote:

I’ve created a service and uloaded a py file. Then I modified the py file
and uploaded it again (in logs upload and distribution went well), but if I
execute it, it executes the old version.
If I look in services, the source code is correct, but it continues to
execute an old version of that service.

I’ve never seen such a thing - does it persist if you restart the server?

If I reboot zato service or the entire server, nothing changes… I can’t
understand.

Tomorrow I try to change service name…

On Thu, Mar 27, 2014 at 5:16 PM, Dariusz Suchojad dsuch@zato.io wrote:

On 03/27/2014 04:38 PM, Giovanni Colapinto wrote:

I’ve created a service and uloaded a py file. Then I modified the py file
and uploaded it again (in logs upload and distribution went well), but
if I
execute it, it executes the old version.
If I look in services, the source code is correct, but it continues to
execute an old version of that service.

I’ve never seen such a thing - does it persist if you restart the server?


Dariusz Suchojad

https://zato.io
ESB, SOA, APIs and cloud integrations in Python

On 03/27/2014 05:35 PM, Giovanni Colapinto wrote:

If I reboot zato service or the entire server, nothing changes… I can’t
understand.

Tomorrow I try to change service name…

Ok, if after rebooting it still persists it most likely means it wasn’t
actually deployed.

How do you confirm it’s actually deployed?