(Migrated) Scheduling jobs

(This message has been automatically imported from the retired mailing list)

Hello.

I just made a very simple service which does a GET on an external source.

I then added a “one-time” Scheduler job. So far, so good. Hitting
"Execute" does trigger the service and it does what it’s supposed to do.

But, the logs get cluttered with the error messages below and after a
while, the whole job is set inactive.

https://zato.io/docs/progguide/examples/scheduler.html does not mention
anything about active statuses and so on. Google didn’t find anything
useful either.

Bug or me doing something wrong (again)?

Thomas.

2015-06-16 14:12:04,784 - ERROR - 26131:Dummy-4245 -
zato.scheduler.job.set-active-status:22 - Can’t run before_None_job,
e:[Traceback (most recent call last):
File
"/opt/zato/2.0.4/zato-server/src/zato/server/service/init.py", line
680, in call_job_hooks
func = getattr(self, func_name)
AttributeError: ‘SetActiveStatus’ object has no attribute ‘before_None_job’
]
2015-06-16 14:12:04,794 - ERROR - 26131:Dummy-4245 -
zato.scheduler.job.set-active-status:22 - Can’t run after_None_job,
e:[Traceback (most recent call last):
File
"/opt/zato/2.0.4/zato-server/src/zato/server/service/init.py", line
680, in call_job_hooks
func = getattr(self, func_name)
AttributeError: ‘SetActiveStatus’ object has no attribute ‘after_None_job’
]
2015-06-16 14:12:04,794 - ERROR - 26130:Dummy-12531 -
zato.scheduler.job.set-active-status:22 - Can’t run after_None_job,
e:[Traceback (most recent call last):
File
"/opt/zato/2.0.4/zato-server/src/zato/server/service/init.py", line
680, in call_job_hooks
func = getattr(self, func_name)
AttributeError: ‘SetActiveStatus’ object has no attribute ‘after_None_job’
]

On 16/06/15 14:00, Thomas Lundquist wrote:

AttributeError: ‘SetActiveStatus’ object has no attribute ‘after_None_job’

Hi Thomas,

this is a harmless message which doesn’t influence anything but will be
taken care of in 2.0.6. Thanks for reporting it.