(Migrated) Notes to deploy zato-lbagent as a service

(This message has been automatically imported from the retired mailing list)

I like to share an experience that cost a tons of hours to me when trying
to deploy zato-lbagent component as a service in Ubuntu 14.04 server, but
could happens in any other environment that someone are trying to do it.

1- I tried to run “zato start” command using an non-root user and having
configured the zato-lbagent/config/repo/zato.config binding the frontend to
port 443 with ssl config. This cause that haproxy cannot start because
non-root users cannot open that port. Changing the user to root in the
init.d script works ok, I know that haproxy have chroot and drop privileges
options, I will check out for a more stable config

2- I use a PATH variable in my /etc/init.d script and seems that haproxy is
afected by this particular variable causing that it cannot find any config
files that “zato start” command is passing to the execution of the haproxy,
I not using that variable PATH, I has been inherited from others startup
scripts that I was using before, so commenting the line works ok

This are not Zato related bugs, just notes to share to help others to
prevent this mistakes in the future.

Cheers

Another one is that to allow haproxy to be configured with ssl, I need to
compile the haproxy 1.5-dev with make option USE_OPENSSL=1, The version
that Zato install does not support SSL, at least in my setup environment

Hope this helps

On Wed, Jul 30, 2014 at 5:05 PM, Axel Mendoza Pupo aekroft@gmail.com
wrote:

I like to share an experience that cost a tons of hours to me when trying
to deploy zato-lbagent component as a service in Ubuntu 14.04 server, but
could happens in any other environment that someone are trying to do it.

1- I tried to run “zato start” command using an non-root user and having
configured the zato-lbagent/config/repo/zato.config binding the frontend to
port 443 with ssl config. This cause that haproxy cannot start because
non-root users cannot open that port. Changing the user to root in the
init.d script works ok, I know that haproxy have chroot and drop privileges
options, I will check out for a more stable config

2- I use a PATH variable in my /etc/init.d script and seems that haproxy
is afected by this particular variable causing that it cannot find any
config files that “zato start” command is passing to the execution of the
haproxy, I not using that variable PATH, I has been inherited from others
startup scripts that I was using before, so commenting the line works ok

This are not Zato related bugs, just notes to share to help others to
prevent this mistakes in the future.

Cheers