(Migrated) How to make services available from outside

(This message has been automatically imported from the retired mailing list)

Hi

I have tried the tweaks described here:
https://mailman-mail5.webfaction.com/pipermail/zato-discuss/2013-November/000102.html

I am running an ubuntu vm on virtualbox. From the host os ( win 7 ) I
cannot invoke any services on the guest os ( the zato vm )

Connections time out. Before doing the tweaks, they were refused.

I am probably missing something obvious, as I am both a zato and virtualbox
newbie.

Any further tips to share?

-Bad

I am guessing its a virtualbox issue. It all depend on your network setup
for the Virtualbox instance. ie. bridged vs NAT. Or other. Your windows
network may not be able to see the host even though you have access to the
internet from the host.

On Fri, Jul 25, 2014 at 11:48 AM, Dariusz Suchojad dsuch@zato.io wrote:

On 25/07/14 14:34, Baad Sequel wrote:

I am running an ubuntu vm on virtualbox. From the host os ( win 7 ) I
cannot invoke any services on the guest os ( the zato vm )

Connections time out. Before doing the tweaks, they were refused.

Hello Baad,

can you please send across the relevant parts of both the
load-balancer’s and server1’s main config files?

Assuming the environment is in /opt/zato/myenv, the paths will be,
respectively:

  • /opt/zato/myenv/load-balancer/config/repo/zato.config
  • /opt/zato/myenv/server1/config/repo/server.conf

Relevant here means

  • front_http_plain.bind for LB
  • main.gunicorn_bind for the server

thanks a lot,


Dariusz Suchojad

https://zato.io
ESB, SOA, REST, APIs and cloud integrations in Python

On 25/07/14 14:34, Baad Sequel wrote:

I am running an ubuntu vm on virtualbox. From the host os ( win 7 ) I
cannot invoke any services on the guest os ( the zato vm )

Connections time out. Before doing the tweaks, they were refused.

Hello Baad,

can you please send across the relevant parts of both the
load-balancer’s and server1’s main config files?

Assuming the environment is in /opt/zato/myenv, the paths will be,
respectively:

  • /opt/zato/myenv/load-balancer/config/repo/zato.config
  • /opt/zato/myenv/server1/config/repo/server.conf

Relevant here means

  • front_http_plain.bind for LB
  • main.gunicorn_bind for the server

thanks a lot,

On 25/07/14 14:34, Baad Sequel wrote:

I am running an ubuntu vm on virtualbox. From the host os ( win 7 ) I
cannot invoke any services on the guest os ( the zato vm )

Connections time out. Before doing the tweaks, they were refused.

Hello Baad,

can you please send across the relevant parts of both the
load-balancer’s and server1’s main config files?

Assuming the environment is in /opt/zato/myenv, the paths will be,
respectively:

  • /opt/zato/myenv/load-balancer/config/repo/zato.config
  • /opt/zato/myenv/server1/config/repo/server.conf

Relevant here means

  • front_http_plain.bind for LB
  • main.gunicorn_bind for the server

thanks a lot,

Thanx a lot guys.

Bridged network together with the tweaks referenced earlier did the trick.

-bad

zato.config:

##############################################################################

frontend front_http_plain

mode http
default_backend bck_http_plain

option httplog # ZATO frontend front_http_plain:option log-http-requests
bind 0.0.0.0:11223 # ZATO frontend front_http_plain:bind
maxconn 200 # ZATO frontend front_http_plain:maxconn

monitor-uri /zato-lb-alive # ZATO frontend front_http_plain:monitor-uri

server1.server.config:
[main]
gunicorn_bind=0.0.0.0:17010

On Fri, Jul 25, 2014 at 6:38 PM, Brian Martin bmartin@qualbe.com wrote:

I am guessing its a virtualbox issue. It all depend on your network setup
for the Virtualbox instance. ie. bridged vs NAT. Or other. Your windows
network may not be able to see the host even though you have access to the
internet from the host.

On Fri, Jul 25, 2014 at 11:48 AM, Dariusz Suchojad dsuch@zato.io wrote:

On 25/07/14 14:34, Baad Sequel wrote:

I am running an ubuntu vm on virtualbox. From the host os ( win 7 ) I
cannot invoke any services on the guest os ( the zato vm )

Connections time out. Before doing the tweaks, they were refused.

Hello Baad,

can you please send across the relevant parts of both the
load-balancer’s and server1’s main config files?

Assuming the environment is in /opt/zato/myenv, the paths will be,
respectively:

  • /opt/zato/myenv/load-balancer/config/repo/zato.config
  • /opt/zato/myenv/server1/config/repo/server.conf

Relevant here means

  • front_http_plain.bind for LB
  • main.gunicorn_bind for the server

thanks a lot,


Dariusz Suchojad

https://zato.io
ESB, SOA, REST, APIs and cloud integrations in Python