Error in web-admin when listing subscribers

Hey there!

I am getting the following error when accessing the web-admin menu option Pub/sub > Subscriptions:

Traceback (most recent call last): File "/opt/zato/3.0/code/zato-web-admin/src/zato/admin/web/views/", line 416, in __call__ view_specific = self.handle() File "/opt/zato/3.0/code/zato-web-admin/src/zato/admin/web/views/pubsub/", line 94, in handle create_form = CreateForm(self.req, data_list) File "/opt/zato/3.0/code/zato-web-admin/src/zato/admin/web/forms/pubsub/", line 94, in __init__ add_select(self, 'endpoint_type', PUBSUB.ENDPOINT_TYPE(), needs_initial_select=False, skip=skip_endpoint_types) File "/opt/zato/3.0/code/zato-web-admin/src/zato/admin/web/forms/", line 53, in add_select for elem in elems: TypeError: 'ENDPOINT_TYPE' object is not iterable

If you go to Pub/sub: Topics and you click on any of the Subscriptions links (i.e. the demo one or the one I created for my application), you get the same error.

Can you tell me what the Zato version and your branch are? Thanks.

Just checked using git branch and it’s support/3.0. I thought it was main. I’ve been updating Zato by just running git pull for the last few months. Just git-pulled yesterday afternoon after the fix for the key when clearing the cache definition from its items. Still using Python 2.7, not 3.x.

Should I be using the main branch?

Branch support/3.0 is fine if you want to use Zato 3.0 - only backports and stability fixes go to it.

If you switch to main, which is a development one and in June will be turned into support/3.1, this will require you to create a new environment and recreate it periodically because for sure various backward-incompatible changes are added to it.

What goes to main is stable but possibly not compatible with your environment if you just git pull so you will have to recreate it more often until 3.1 is released.

Once support/3.1 becomes available, again, it will become the current stable branch so only backward-compatible changes will go to it and main will be the development one as it is today.

As for your original question - can you try it now after git pulling the updates?

Okay, then I’ll stick to the support/3.0 branch for now and give the main branch a try in a separate Docker container to test Ubuntu 18.04 and Python 3 altogether.

And yes, the fix worked. Cheers! :+1: