Deploying pubapi services

I have set the pubapi password as discussed previously.

When I try to invoke a service like zato.security.rbac.role.get-list I found that:

  • the service can be called using the cli ‘zato service invoke …’ but
  • not from ‘curl host:11223/zato/json/…’ which returns:

{
“zato_env”: {
“details”: “Traceback (most recent call last):\n File “/opt/zato/3.0.0/zato-server/src/zato/server/connection/http_soap/channel.py”, line 206, in dispatch\n payload, worker_store, self.simple_io_config, post_data)\n File “/opt/zato/3.0.0/zato-server/src/zato/server/connection/http_soap/channel.py”, line 338, in handle\n service = self.server.service_store.new_instance(channel_item.service_impl_name)\n File “/opt/zato/3.0.0/zato-server/src/zato/server/service/store.py”, line 93, in new_instance\n return self.services[class_name]‘service_class’\nKeyError: u’zato.server.service.internal.security.rbac.role.get-list’\n”,
“result”: “ZATO_ERROR”,
“cid”: “ffc42856bf1cc6c10cec32df”
}
}

Checking in the webgui I see that in the service overview under Deployment info the service is marked as "(Service isn’t deployed on any servers) " which explains why the curl call fails.

How do I install/enable these services so that I can access them?
Do I need to add them to service-sources.txt explicitly?